Topic 3:

DC Simulations and
sub-circuit modeling
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DC Simulation

You get steady-state DC voltages and
currents according to Ohm’s Law: V= IR

« Capacitors = treated as ideal open circuits

* Inductors = treated as ideal short circuits

» Topology check: dc path to ground (if not => error message)
« Kirchoff's Law satisfied: sum of node current =0

« Convergence simulator algorithms (modes) can be set
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Palette and editor (dialog box)

()
------

DC simulation controller

IShnuIaﬁun—DE

[

Sweep '{ﬁi
Flan

PrimnSwp

HdSet
NdSet Hanme

Dizp Meas
Temp Eqn

> | &R [oc

(]
D1
Sweephar="yre"

Sweep: allows you to sweep

a parameter but it must be declared
as a variable. Note the dialog entry
automatically puts quotes on the

controller (screen) entry.

VAR =)

..~ Agilent Technologies

| = VAR
VAR
Vee=3V

DC Operating Point Simulation:1

OC Ingtance Mame

Sweep |F'arameters| Dutputl Displa_l,ll

Swept Variable in controller

Parameter to sweep |'-,,-',3E

— Parameter sweep DE
Sweep Type Im
& Stat/Stop Center/Span
Start IEI INDne j
Stop |5 INDne j
Step-zize ID_-l I j
Murm. of pts. IE'I—

[~ Use sweep plan I VI

Ok Apply Cancel Help |
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...more on DC

DC Instance Mame

Sweep Parameters | Dutputl Displayl

———

T LOnvergence

tan. Delka Walkz

0.0

Py, |berati
Mo lerstirs o1 | —

Mode I.ﬁ.utu:u FEqUENCE

~

[

—Levels

Status level |2_

§end to

dataset.

— Device operating point lewvel

¢ Mone @ Bnef " Detaled

— Dutput zolutionz

[~ Output solutions at all steps

Convergence: increase V or
iterations or change mode if

you don’t converge.

()
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Sirmulate

Avalilable after
simulation on
schematic.

Simnulate F¥
Simulation Setup.... 5
Stop and Beleaze Simulatar

Tuning...

Highlight Hode...

Clear Highlighting Fa

Annatate DC Solution
Detailed Device Operating Point I
Brief Device Operating Point
Clear DC Annatatian

Ilpdate Optimization alues

_ + Device Dperating Foint:1
I= —0.00101%7% -
FPower —0.00203541
s : You get V, |,
V_SOURCE SEC1 and Powerl
I= —0.00101%77
Fower —0.00203541
V= 2
1| | »
DK I Print | [ Clear | Help |
T ¥
| + W_0C
e SR 1
| —wde=2.0 ¥
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Schematic Annotation of DC values

Immediately after DC simulation, click: Simulate > Annotate DC Solution.

Simulate >

Clear it here

Annotate DT S olution

Detalled Device Operating Paoint
Brief Device Operating Point

/ Clear DT Annotation

No controller settings necessary!

5\

(3.34 mA

—v DC

SRCA1
Vde=5 'V

R 3.34 mA
RC
R=590 Ohm
3.03V
_ 3.03V 1 VC
39.8 uA '3.03 v
799 3.31 mA
R | VBE bjt_pkg
RB  308UuA [ @1
R=56 kOhm beta=160
-3.34 mA
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A DCI

DC
DCA1

Minus sign used for current
flowing out of a connection.
Otherwise, current flows into
a connection or device.

DC Simulation Controller is

required in all simulations if
you want DC annotation.
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) ¢
Class Exercise

Set these before you start the next exercise!

HOT KEYS and
Schematic Preferences
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Default Hot Keys for commands

Pre-configured keys:

F7 = Simulate
{F5) = Move Component Text

Ctrl+R = Rotate 90

Ctrl+M = Move If you don’t like mouse clicks,
Ctrl+C = Copy HOT KEY your keyboard.
Its global for all projects
Ctrl+Z = Undo J Pro)
lus more...
p ) % Wout é_
. . -l |
— Try this now: click the F5 key, o _T_
select the Mixer component, move a 'L'“F;;?: | =
the cursor and the text will follow! ! e |
v ) dqveaimdhpnlar(a,uj |
1z S1J =polari0,0) |
|

= Sa§=pnlar(0,1 a0
S33=0

Hot Keys are global for all projects! =

“i.i~ Agilent Technologies ADS 2001 Fundamentals - Sept, 2005]ide 3 - 7



Set your own Hot Keys

Now, click: Options > Hot Key / Toolbar Configurations...

i Configuration: 3 Ed
Hot ey | Toaolbar |

Categomny [termn
Edit\\ ertes’, ﬂ YWigw Al
E dithkdodify’, Parn Yiew

<-E'EIEEET Redraw

e ety actar e e
Dirawt, Zoom Dut Point
Componenth, Restore Lazt Wiew
Optiofiz' ﬂ Save Wiew... j

Zoom To Designated Area

Current Hot ey

— Mew Hat Key
[] Chl
[ Al Key:
[~ Shitt

Reset |
Clear |

. o~
] | Q Apply | Eancell Defaultl Help |
S ————

Agilent Technologies

Follow these steps to set
Zoom Area command:

1. Select the command

2. Type in a letter: z
(not case sensitive)

3. Click: Assign

4. Click: Apply

5. Now, try the Z hot key
to verify it works.

>
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Set a few more Hot Keys

Options > Hot Key / Toolbar Configurations...

S = Simulate > Setup
A = Activate
D = Deactivate
X = Edit > Move > Move & Disconnect s
o @)
rmt'ft . IZ— %I
and any others you want ... — -
® | ( ﬂ ) Careel | Defaul He |
You will be able to use these hotkeys
for all the labs in this project.
When everyone has finished, continue ! >
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If desired, set Schematic Preferences

Click: Options > Preferences

Go to the Display
tab to set a different

Unitz/Szale

Select Grd/Snap l F'Iau:ement] F'in.-’Tee] Entrya’Edit] EnmpnnentTe:-ct] Text

Grid/Snap background color.
: Display — | Gpunna Displﬂjl -
' | g Click None to
. || . — Color
e p remove the grid dots.

_ Foreground B -
| Grid Display Factor —

. X |2 LAV | B ackground

| [ Snap Distance - all other modes —

| " Lines

i MHone

Highlight - -

|| Diameter Units _
| 15 screen pixels __j | e

| Color -] SR [ SetAll | Clearall |

i N Save schematic.prf and settings will

~
R (Amﬂy ]) Reset | (s |) Read.. | | apply to all schematics in the project.
\/

NOTE: Set wire color in: Options > Layers. * End of class exercise.
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AR

What the lab is about ...

Lab 3:

DC Simulations and modeling

Agilent Technologies

the sub-circuit

&

=

1 Fundamentals - Sept, 2@] Ide 3 - 11



Steps in the Design Process

» Design the rf_sys behavioral model receiver

» Test conversion, budget gain, spectrum, etc.
You are here: | >- Start amp 1900 design — subckt parasitics

 Simulate amp DC conditions & bias network

» Simulate amp AC response - verify gain

» Test amp noise contributions — tune parameters

» Simulate amp S-parameter response

» Define amp matching topology and tune input

» Optimize the amp in & out matching networks

* Filter design — lumped 200MHz LPF - use E-Syn

£3 o Filter design — microstrip 1900 MHz BPF

» Transient and Momentum filter analysis
EJ « Amp spectrum, delivered power, Zin - HB
e Test amp comp, distortion, two-tone, TOI

» CE basics for spectrum and baseband

e CE for amp_1900 with GSM source

* Replace amp and filters in rf_sys receiver

» Test conversion gain, NF, swept LO power
» Final CDMA system test CE with fancy DDS
o Co-simulation of behavioral system
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Start with some specifications...

AMP with max gain & low noise:

Available voltage: 5 volts

Device: Generic BJT (Gummel-Poon)
Collector current: about 3.25 mA
Frequency: RF = 1900 MHz

Gain: > 15 dB (or much more with this model)
50 ohm match: input and output

Later labs: matching and testing the AMP for TOI, distortion, noise,
compression, GSM & CDMA modulation response, and more.

Filters: also, build 1900 MHz BPF for the input and a LPF for the IF output

YOUR JOB: Build, test, and refine the circuits to meet specifications.

Start by modeling the sub-circuit... >
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Device with package parasitics
G-P Model Card, BJT symbol, parasitics, and ports.

|nevi.;f,5-|3JT Port connector
/ numbers: Num=
‘ﬁ Oﬁum must be set in specific

BJT : “ﬂ
Symbol fa[\esrte order as shown - this

+ | = et L2 is necessary to
B ﬁ /v g#:Tbhgla g L=320 pH | BJT
G-P MV/ Br-bel g = correctly use
Model ;! ], L=320 pH symbol.

BT =
Card F=0.01 Ohrn l
= L4 FJ.?T\T—‘ BJT1 i1
X M M Model=BJThi1 C=1201F

STEIT | EEBTZ o3

B _ [ >
_% _% Hurne3 C=1201F Ao
\behPH | WhoPhP 'y

Model Card e i BJT Symbol:
parameters: L in pico: pH : : Name of model card
Sl & presee C in femto: fF ON“"”=3 . BJTM1 used for
parameter. E . . .
Vaf is changed as . Simulation. Library.
e devices do not require

: this mapping.
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Viewing and creating a schematic symbol

P

Schematic view

“ate
------

Create/Edit Schematic Symbal

Ele Ed heea few liwe Conposssr [pied [roi Lo Apsdes  edes

Emmpla s Hefs

|Lurmpe é-Camponenm =] Fon

e i e O e e i e R

JMI%HH]H*

=

alit b1t b o a2

It t[ed pa e o B [ |4

3
o Sty ] L

bjt_pkg
Q1

Agilent Technologies

| "
BT MBI et 205D L

Symbol view

Create/Edit Schematic

mwww—hmmmml—m

e ] ] i 2] 9l R 1L‘II_I_I Rl

[Lameed Canperanis

5|F uI|MH|J|*

4

1 2

— Sl Typs

F Ludl

-l" D.,nl

Dncer Fona by

& Laafion

I~ Mwba
R rA T e
Lozd Langi

[=

Distarice Bebwesn P
=

[0 ] pew | coeel| Rep |

Default Symbol or
delete and draw a
symbol.

Or, to get this NPN BJT symbol with your
beta=160 annotation, use: File > Design Parameters.

—>
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Design Parameters for your schematic

Click: File > Design / Parameters

Dezign Parameters: 3

M ame; ||:uit_|:|kg

General l Parameters ]

Drezcrphion

Pararneters

Select Parameter

|bit_pka

Component Instance Mame

[¥

Symbaol Mame

 Description for library annotation
 Component Instance name: Q

[SYM_BJT_NPN
Library Mame

i

Mate: &0 " indicates current project.

[ Allow anly one instance
[ Include in BOM
[ Layout Object

[ Simulate from Layout [SimLay]

Simnula
todel
&1 Symbol: SYM_BJT_NPN
3 o Passed parameter for Bf = beta

— Edit Parameter

Parameter Mame

|I:ueta
YWalue Tope

I Real
Default Value [e.q., 1.23e-12]

|'I B0
— Optional

FPararmeter Type

I Unitlesz

Parameter Description

[+ Dizplay parameter an schematic
[+ Optirmizable

v Allowe statistical distibution

I~ Mat edited

™ Mat netizted

Artwork, I

Tupe

|Fi:-:eu:| ﬂ Add I Cut | Faste |

Marme Add Multiplicity Factaor [_k] |

m} ﬂ Copy Parameters From... |
Cancel |

Help |

You can specify a
layout: built-in sot23

You can copy parameters
from other library models.
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Insert the model In a new schematic

@ Insert the sub-circuit from the library.

= [ mixer_prj ] bjt_pkg [Schematic]-4

Fil= Edit Select “iew Draw Component Optionz Tool: Lapout  Simulate  window

i Component Library/5chematic: 20 DesignGuide Help

. File Edit “iew Options Tools Help Dl@l [ﬂ %l %l U'*ﬂ U‘UD :} | @l.ﬁ:l ‘%’FQ'Q +2C{ _Z)C{
Eb Iﬂllg ;’éll%l @ ++|__|+|_‘ ISimuIatinn-DC jl j | =
Libraries Components @ [

= Al ) 0G | Options
= Sub-retwork sween| | 43537 ;
o150 () | e Design
Frequently Used Analog/RF Ca hsen parametel’s
/ | follow the
bjt_pkg : .
Q1 sub-circuit:
LB | wive g [t g obemnad MK beta=100
. K Sl o g ot Bl Dk bt Sl M = Q1, beta, etc.
| = S T L e 1 S N N . | ]
[Sirmlbanc = d.}l-_-lg Select: Enter the starting point 0items idertifiers 22
=
. ‘i‘ i‘ ICONS: Push into and
) hdhdl Pop out of the hierarchy.

| >
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Set up a DC curve sweep with atemplate

This template also has a data display template.

DisplayTemplate
dispternp
"BJT_curve_tracer"

|€% PARAMETER SWEEP I
. aramgweep

Sweep
SweepWar="|BEE"
SiminstanceMame[1]="DC1"
- SiminstanceMName[2]=
 SiminstanceMame[3])=
SiminstanceMame[4]=
" SiminstanceName[5]=
- SiminstanceMame[g]=
o Start=0 uA
. Stop=100 uA
C Step=10 uA

+ V_DC |_Probe
- =ske] . IC
Vdo=VCE ..

Probe give current

b-Jt_pkg' '
oy .
heta=160

@VAR'

VAR
WCE =0%

Det IBE =0 A

Sweepvar="vCE'

Start=0 '

- Stop=5
¢ Step=0.1

Initialized VARs: VCE=0V & IBB=0A

NOTE: DC controller sweeps the X-axis and the
Parameter Sweep, sweeps the Y-axis.

Agilent Technologies

current in dataset.

Your model (bjt_pkg)
with annotation and
passed parameter: beta.

Data Display template

gives curve tracer results:

IBE=1.000E-4
IEE=59.000E-5
6 — IEE=8.000E-5
IBE=7.000E-5
-E 4 | i IEE=G.000E-5
= — v BB DODE-2
g =V R
VCE=3.000000 - -
0 IBB=0.000040 [BE=4 BREF-°
1 IC.i=0.002460
-2 T T T T | T T T T | T T T T | T T T T T
0 1 2 3 4 5
VCE

——>
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Finally, calculate and test a bias network

Setup a new sweep: then use voltage and current
to calculate R values for the DC specs for Ib and Ic.

oy
= | ﬂ} DC
1] o0
|_Probe D1
IC Sweepvar="IEB"
+| voc Start=10 U
==pc hit_pkg Stop=100 uA
-T vde=av ar Slip={0 uh
beta=160
= VAR
VAR
do=IBE B8 =0 A
R 3.34 mA
RC
5\ R=580 Ohm
303V
303V VC
A B03V
+ 3.34 mA
—V_DC 3.31 mA
\ngcC:s v R o™
RB  39.8 UA Q1
: . beta=160
Back Annotation verifies 334 mA

DC bias using Rb and Rc

as designed.

()
------

Agilent Technologies

IBE BE ICi
1.000E-5 754 anmy 599 0uA
2 000E-5 TTT.AmY 1.430ma
3.000E-5 75991 2 3451

[ 4.000E-5 798.8mY 3.325mA]
5 O00E-5 505 71 134TmA
6 .000E-5 B11.3my 5.365MmA|
7 000E-5 B15.9my 6.462ma|
8.000E-5 819.9my 7.557ma|
9.000E-5 823.5my B8.669mA

Rb:(S-HBE] | BE 1.000E-4 826 6mY 9.798mA

BRI Rc=2/(ICii + IBB) \

Bias Resistor Calculations

Rb[3] Rc[3]

55029.037 594.350

OPTIONAL: Sweep Temperature

35

Jn1

m1

257 temp=-55.000
plot vs(VC, temp)=3.079)
w 4
Eg 20
b m3
15+ temp=-2% 000

plot_ws{VEE, temp)=0.899

E"n3

3_UEM

Start the
A lab now!
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Ansys AFSS
REAER TN gl g 6 IWBIIELR LRI, RIS, AR,

f Qf’?‘ﬁﬁ HS A SR SE PR R PR 45 &, AT R AR T HFSS K&K
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