
ADS Fundamentals - 2001

LAB 3: DC Simulations and Circuit Modeling

Overview - This chapter introduces the use of behavioral models to create a
system such as a receiver. This lab will be the first step in the design
process where the system level behavioral models are simulated to
approximate the desired performance.  By setting the desired specifications
in the system components, you can later replace them with individual
circuits and compare the results to the behavioral models.

  

OBJECTIVES

? Model a generic BJT with parasitics and save it as a sub circuit.

? Set up and run numerous DC simulations to determine
performance.

? Calculate bias resistor values in the data display.

? Build a biased network based on the DC simulations.

? Test the biased network.
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PROCEDURE

The circuit you bulid for this lab exercise will be used as the lower level
hierarchial circuit for all of the amplifier labs to follow.

1. Set up and new project and schematic.

a. Create a New Project and name it: amp_1900.

b. Open a New Schematic Window and save it as: bjt_pkg

2. Set up a generic BJT device symbol and model card

a. Insert the BJT generic device and model card: In the schematic
window, select the palette: Devices–BJT.  Select the BJT-NPN
device shown here and insert it onto the schematic.

b. Insert the BJT_Model (model card) shown here.

c. Double click on the BJT_Model card. When the dialog appears,
click Component Options and in the next dialog, click Clear All
and OK. This will remove the Gummel Poon parameter list from
the schematic.

NOTE on Binning: You can insert multiple model cards and use the Binning
component to vary the model device variations.  These variations can be

NOTE: The BJT_NPN symbol shows
Model  = BJTM1. This means the
symbol will use that specific model
(model card) on for simulation.
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parameters such as temperature, length or width. The Binning component
allows you to create a matrix that references the desired models.

a. Double click on the BJT_Model you just inserted.  Select the Bf
parameter and type in the word beta as shown here. Also, click
the small box: Display parameter on schematic for Bf only and
then click Apply.  Beta is now a variable you can tune.

b. Set Ise (E-B leakage) = 0.02e-12, and display it by
clicking the check box and Apply.

c. Set Vaf (Forward Early Voltage) = 50 and display
it. These parameters give some reality to the
model.

d. Finally, for the BJT device, remove the unwanted
display parameters (Area, Region, Temp and
Mode) by unchecking the box.  This will make the
schematic less  crowded with parameters that you will not be
using.

Afterward, click
here to display
an individual

First, click on
Component Options
to clear all the
displayed
parameters.
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3. Add parasitics and connectors to the device.

The picture here shows the completed sub-circuit with connectors and
parasitics.  Remember to use the rotate icon for orientation of the
components as you insert them.  Here are the steps:

a. Insert the lumped L and C components: Insert three lead
inductors (320 pH) and two junction capacitors (120 fF).  Be
sure to use the correct units (pico and femto) or your circuit
will not have the correct response.  Also, add some resistance
R= 0.01 ohms to the base lead inductor and display the desired
component values as shown.

b. Insert port connectors: Click the port connector icon (shown
here) and insert the connectors exactly in this order: 1)
collector, 2) base, 3) emitter.  You must do this so that the
connectors have the exact same pin configuration as the
ADS BJT symbol.

c. Edit the port names as show here: change P1 to C, change P2 to
B, and change P3 to E.

Clean up the schematic: Position the components so the schematic looks
organized – this is good practice.  To move component text, press the F5-
Key and then select the component. Use the cursor to position the text.

NOTE: You must
number the ports
(num=) exactly
as shown or the
device will not
have the correct
orientation for
the symbol that
will be used.
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4. Create a symbol for the sub-circuit

There are three ways to create a symbol for a circuit: 1) Use the
default symbol, 2) Use a built-in BJT symbol, or 3) Draw your own
sysmbol.  For this lab you will use a built-in BJT symbol. The
following steps show how to do this:

a. To see the default symbol, click: View > Create/Edit
Schematic Symbol.  The symbol view will replace
the schematic and a dialog will appear.  Click OK.

b. Next, a box or rectangle
with three ports is
generated.  This is the
default symbol. However,
delete this symbol using
the commands:  Select >
Select All. Then click the
trash can icon or delete
key.

c. Return to the schematic.  Click: View > Create/Edit Schematic.

5. Set up the schematic Design Parameters.

a. Click File> Design Parameters and the dialog appears

b. In the General tab, make theses changes: 1) change the
Component Instance Name to Q,  2) change the Symbol Name to
SYM_BJT_NPN by clicking the arrow and selecting it (this is
the built-in symbol), 3) in the Artwork field, select Fixed and

Default
symbol

Built-in symbol:
SYM_BJT_NPN

SOT23 fixed
artwork
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SOT23 as shown here.

c. Click Save AEL File to write these changes but do not close this
dialog yet because you still need to set other parameters.

d. Go to the Parameters tab.  In the Parameter Name area, type in
beta and assign a default value of 100 by clicking the Add
button.  Then cleck the box to Display the parameter as shown
here. Click the OK button to save the new definitions and
dismiss the dialog.

e. In the schematic window, Save the design (click
the icon shown here) to make sure all your work
creating this sub-circuit will not be lost.  In the

The parameter beta is
now recognized as a
parameter of this
circuit.  Its value can
now be passed
(assigned) from
another circuit as you
will see.

NOTES: mutiplicity _M

You can define multiple
components in parallel.
You can also copy
parameters from
another device or file.
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next steps, you will see how the Design Parameters will be used.
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6. Use a curve tracer template to test the bjt_pkg subcircuit.

a. In the current schematic of the bjt_pkg, click File > New Design.
When the dialog appears, type in the name: dc_curves and
select the BJT_curve_tracer template as shown. Click OK and a
new schematic will be created with the template, ready to insert
bjt_pkg.

This is a data
display template –
it will
automatically plot
the curves.



Lab 3: DC Simulations

3-10

b. Save the design and then click the
Component Library icon (shown here).

c. When the dialog opens, select the amp_1900
project and click on the bjt_pkg sub-circuit
and insert it into schematic as shown here.  Every circuit that
you build will be available in the project library as a sub-

circuit.

   

d. Connect the bjt_pkg component
as shown. You may have to
adjust the wires and text (F5) to
make it look good.  Also, you
can now close the library
window and save the dc_curves
design again - it is good
practice to save often.

  

NOTE on templates: You can also insert templates
using the schematic window command: Insert >
Templates.  Many templates have predefinedvalues,
node names (wire labels), and variables.
Therefore, you may have to make modifications to
fit your circuit.  Also, many of these templates
have data display templates to automatically plot
the data.  These same data display templates are
available in the data display window.  In general,
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using templates is very efficient and time-saving if you know how to use
ADS.
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7. Modify the template Parameter Sweep.

a. Change the Parameter Sweep IBB values to: 0 uA to 100 uA in
10 uA steps as shown here. Do not change the DC simulation
controller default settings for sweeping VCE – they are OK.
Notice that the VAR1 variables (VCE=0 and IBB=0) do not
require modification because they are only required to

initialize (declare) the variable for the simulator.

8. Simulate at beta=100 and 160.

a. Simulate (F7) with Beta = 100:
After the simulation is finished,
the data display should
automatically appear with the
curve tracer results. Try moving
the marker and watch the
updated values appear.

b. Simulate again with Beta
= 160: On the schematic,
change the value of beta
= 160 and simulate again.
You should see the
updated values:

VERIFY for beta = 160 and VCE = 3V: IBB=40 uA
and IC=3 mA with about 10mW of consumed power.

Parameter sweep used for
multiple variable sweeps.
Note that DC1 is the name
(SiminstanceName) of the
simulation controller.

Only one variable
can be swept in
the   controller.

VarEqn is
required to
initialize

DC Curves at
beta = 100
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9. Open a new design and check all your files in the Main window.

a. Save the current schematic. In the same window, create a new
design (without a template) named: dc_bias.  Click on
the Save Current Design icon (shown here) so that
the current design is written into the ADS database.

b. Now, check the ADS Main Window: you should have 3 designs
in the networks directory: bjt_pkg, dc_curves, and dc_bias. You
may have to click the file browser networks to refresh.

  

c. In the File Browser area, click on the plus /  minus boxes and
the up arrow (or two dots). This allows you to see the files you
have created in this project.  Remember: you can only work in
one project at a time, but you can copy files from other projects

and bring them in.

d. Finally, try the Show / Hide all windows feature.
This is used for security or to find other open

Project and directory
path  are shown here.

Try clicking the
plus (expand)
and minus
(contract).boxes.

Try the up arrow.

Click here to
refresh or reread
the database.
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windows that are not ADS.  In this case, only the Main window
remains.
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10.  Set up a new schematic and simulate with a parameter sweep.

NOTE on setting up a parameter sweeps: If only one variable is swept, use
the Simulation controller (Sweep tab).  However, if more than one
parameter is swept, a Parameter sweep component is required as in the
templates you just used.  In general, all simulation controllers allow you to
sweep only one parameter or variable.

BUILD the circuit  - insert components and then wire it - the steps follow:

a. Insert the bjt_pkg using library icon or the component history.
Now push into the bjt_pkg and click File > Design Parameters.
Reset the beta parameter default to 160, pop out and delete the
bjt_pkg and reinsert it – beta is now 160 whenever you use the
modeled circuit.

b. From the Probe components palette, insert a current probe and
rename it IC instead of I_Probe1 as shown here.

c. From the Sources-Frequency domain palette or using
component history (type in the component name), insert V_DC
= 3 V and I_DC = IBB as shown here. If you edit these
components, you can see they have other parameters which can
be useful in some simulations.

d. Wire the components together and add the ground (ground
icon).

e. From the palette, insert a DC simulation controller.  Edit
(double click) the controller and go to the Sweep tab and assign:
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IBB: 10 uA to 100 uA in 10 uA steps.  Then go to the Display tab
and check the settings to be displayed as shown.  Then click
Apply and OK.
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f. Insert a VAR (click icon) variable equation.  Use the cursor on
the screen to set IBB=0 A.  This must be done to initialize
(declare) the variable to be swept.  Also, if you edit the VAR
you will see how the dialog allows you to add more variables or
edit existing ones.

g. Insert a wire label VBE at the base.  The voltages at that node
will appear in the dataset for use in calculating bias resistor
values.

h. Simulate and plot the data.  When the data display opens,
insert a list of  VBE and IC.i only.  Because you swept IBB
to get these values, IBB will automatically be included.

NOTE on results: As you can see, with 3
volts across the device, 40 uA of current
results in about 799 mV across VBE with
about 3.3 mA of collector current. If you
want, draw a box around the values at 40
uA IBB.

i. Save the design and data display.

11.  Calculate bias values Rb and Rc for a
grounded-emitter circuit

a. In the data display, insert an equation and type: Rb = (3 – VBE)
/ IBB.

b. Select the Rb Eqn
and then use the
keyboard Ctrl C
and Ctrl V to copy
the equation – it
will become Rb1.

c. Highlight the Rb1
equation as shown
and type in the
syntax for Rc = 2 /
(IC.i + IBB).

d. Insert a List, scroll down to the Equations menu (shown here),
and add Rb and Rc.  Then edit both column headings on the list
with a bracketed [3] as shown.  This is because the value of
40uA IBB is in the 4rd position in the array row which begins
with zero: 0, 1, 2, 3, etc.  You can also use Plot Options to add a
label to the list:

Rc

R
b

VB
E

Vc=3V
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12.  Set up a biased network.

Now that you have the calculated bias resistor, you can test the bias
network with resistors Rb and Rc.

a. Save the current design (dc_bias) with a new name: dc_net. By
this time, you should know how to do this (File > Save Design
As).

b. Delete the current source IBB, the I_Probe, and the Var Eqn.

c. Go to the Lumped Components palette and insert resistors for
the base (56 kOhm) and collector (590 Ohm) as shown. Notice
that “R” appears in the history list when you do this.  Also,
with the resistor  attached to your cursor, click the –90 rotate
icon to increment it 90 degrees – then insert it.

d. Change the instance R names to RC and RB as shown.

NOTE on components with artwork: Later on (after the last lab), you can
easily and quickly change to lumped components with artwork by changing
the component name – for example, change R to R_Pad1, C to C_Pad1, L to
L_Pad1, etc. Then you can create a layout of the schematic.  For now, use
the lumped without artwork.

e. Set the V_DC supply: Vdc = 5 V.  Wire the circuit and organize
it.

f. Delete the DC simulation controller and put a new one in its
place – this is faster and more efficient than removing the
sweep settings. Because there is no sweep, you do not have to
set anything to check DC values.

Insert the cursor
and type over to
rename it to RC.
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13.  Simulate and annotate the DC conditions.

a. Use the Simulate > Simulation Setup (or Hot Key “S” if you
have set it) and turn off the opening data display. For this step,
you do not need to have the data display opening.

b. Press the F7 keyboard key and the simulation will be launched
with the dataset name that is the same as the schematic – this
is the default.  You can verify this by reading the status
window:– simply wait for the simulation to complete.

c. Annotate the current and voltage by clicking on the menu
command: Simulate > Annotate DC Solution.  If necessary,
move components or component text (F5 key) to clearly see the
values of voltage and currentt.  Be sure that you have the same
values shown here. If not, check your work, including the sub-

circuit.

NOTE:: Use the
F5 key to move
compnent text.
To move pin/node
names, point-
click-drag,
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d. Clear the annotation, click: Simulate > Clear DC Annotation
and then Save all you work.

14.  OPTIONAL:  Sweep Temperature

a. Edit the DC controller – select it and click the edit icon.

b. In the Sweep tab, enter the ADS global variable temp (default
is Celsius) as shown here and enter the sweep range: -55 to 125
with step size = 5.  Also, in the Display tab, click the boxes to
display the annotation on the controller – click Apply to see it
and OK to dismiss the dialog.

  

c. Insert VC and VBE node
labels.

d. Set the simulation dataset
name to dc_temp, and
check the box to open the
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data display dc_net.  Click Apply and then Simulate.

e. Plot the results in a rectangular plot as VC vs temp and VBE vs
temp  - you should be able to do this as shown:

  

f. Put two markers on
each trace in delta
mode to see the change
in voltage as
temperature changes.
The plot should look
like the one shown
here: collector voltage
decreases at almost
one-half the rate of
VBE as the
temperature increases.
You can use this
temperature sweep
method (sweeping the global variable “temp’) for any
simulation in the future.

                        

   

EXTRA EXERCISES:

1. Use the template SP_NWA_T to generate S-parameters for
bjt_pkg at all the bias points.

2. Plot current (probe: IC.i) vs. temperature. Or, try setting up a
passed parameter for temperature (Temp = 25 in the options
controller). The Options controller is in every simulation
palette and can be used to set convergence for DC and constant
simulation temperature.
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3. Replace the Gummel-Poon model card with another model
(Mextram) and resimulate.  Afterward, compare the results.
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