
ADS Fundamentals - 2001

LAB 6: Filter Design with E-syn, Momentum
and Transient Simulation

Overview -  This chapter shows the fundamentals of creating filters in ADS
and using the Transient simulator. The E-syn interface is used to build a
lumped component filter and Momentum is used to test a microstrip filter.

  

OBJECTIVES

? Build a 200 MHz IF low pass lumped filter using E-syn

? Buile a 1900 MHz RF bandpass filter in microstrip.

? Simulate the filter in Momentum

? Perform a Transient analysis

? OPTIONAL - DAC
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PROCEDURE

1. Change projects.

a. Go to the ADS Main Window and click File > Open Project.

b. Answer Yes to All if you are prompted to save all your current
work and open your earlier project: system_prj.

c. Create a new schematic named: filter_esyn.

2. Use E-syn to create a 200 MHz Low Pass filter.

a. In the new schematic, click: Tools > E-syn > Start E-syn.

b. When the E_syn window first appears, click File > Save As and
give the E-syn file a name: lpf_esyn. Then click the Select Type
button and  select a Lumped, Filter, Chebyshev, Low-Pass and
click OK..

c. In the E-syn main window, set the Frequency spec: ZERO to 0.2
GHz.  It will be used in the RF system output for 100 MHz
IF.

d. Start the E-syn synthesizer by clicking the menu
command Synthesis or click the synthesis icon shown here.

Saving the E-syn
file is like
saving an ADS
schematic.
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e. When the dialog appears, click the Synthesize button and E-syn
will build one or more filters.  In the dialog box, you can see
that 2 filters have been created and 1 of 2 is shown as LCL
filter.  Go ahead and click to select the 2nd filter which is a CLC
topology.

f. Also in the Synthesis dialog, click the Analysis button and a
new Analysis dialog will appear. As shown, set up the
simulation for one Frequency Band 1 - from from 0 to 0.5 GHz,
FSTEP = 0.01 GHz (10 MHz).  Also, select S-parameters and
Group delay.  Click Analyze to simulate the filter response.
Then look in the E-syn main window to see if the analysis is

Simulation of
several bands
is also
available.
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complete.

g. In the E-syn main window, click the Data Display icon. When
the untitled display opens, select the lpf_esyn dataset. Plot dB
of S21 in one plot and then copy it using Ctrl C Ctrl V to get a
second plot and zoom into part of pass band around the 100

MHz IF to see the ripple.

h. Plot S-11 in a Smith Chart and plot GD (group delay) in a
rectangular plot.  Here, S11 at 100 MHz is not 50 ohms and GD
is not very flat.

i. Go back to the E-syn main window and click the Save icon.
Change the Type =  Butterworth.  Click Synthesize and Analyze
the CLC filter: 8.5pF and 42.5 nH. The performance should
improve as shown.

j. Save the data display with
the name: filters.

k. To make it a useable
component  (sub-circuit),

Zoom in on data
specifying a
rectangle.

Add another marker to
see ripple in the pass
band.

Butterworth CLC:
8.5 pF and 42.5 nH.
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go back to the schematic window (filter _esyn) and click: Tools
> E-syn > Place New Design For Synthesized Network – this
menu command only appears after synthesis.  A dialog box will
appear for you to name the filter.  Type in a name and click OK.

l. The E-syn component will be automatically attached to your
cursor – place on the schematic in an open area, select it, and
push into it to see the lumped element sub-circuit.  Afterward,
push out and back to the schematic.  Name the instance on the
schematic if desired, shown here.

m. In the schematic window, click the library icon and verify that
the filter is a sub-circuit (Sub-network) in your project.

n. Close all the E-syn windows and save the schematic window.

Note on using this filter – Later on in the class, you can easily remove the
behavioral model from system design and replace it with this one.
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3. Build a microstrip 1900 MHz bandpass filter circuit

This step will create the system bandpass filter using ADS microstrip
coupled lines and simulated with the ADS circuit simulator. Afterward, you
will transfer it into layout and simulate with Momentum for a comparison
of the results. This step is only intended to briefly show how Momentum
works in the most simple application.

a. Create a new schematic named: filter_ms. This will be the filter
designed in schematic.

b. From the Tlines-Microstrip palette, insert and connect
the microstrip coupled lines (MCFIL) as shown –

because the two end components are symmetrical
(CLin1 and CLin2) so you can save time by setting
up Clin1 and then copying it.  Also, be sure to
connect the terminations with grounds as shown.

c. Also from the Microstrip
pallete, insert the substrate
definition MSUB as shown - no
other settings are required for
this lab.

These two have the same
values.
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d. Set up an S-parameter simulation from 1 to 3 GHz in 10 MHz
steps.
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e. After the simulation, plot
S21 to verify the response.

f. Save the design and data
display.

g. Save the schematic with a
new name: filter_1900.
This is necessary because
you will use this filter
(filter_1900) for your final
system simulation.

h. In the schematic of
filter_1900, click: File > Design Parameters.  When the dialog
appears, select the ADS built-in symbol for a bandpass filter:
SYM_BPF and click OK.

i. In filter_1900, remove the simulation controller, the terms, and
grounds. Insert port connectors as shown here but leave the
MSUB.  Now, the circuit is ready to be used as a sub-circuit.

j.  Save the design again so that all the modifications are also

saved.

k. Save the filter_1900 with a new name for the Momentum
simulation which comes next - save it as: filter_mom.

Saved design: filter_1900 for
use later on in the system.
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4. Momentum simulation from layout

a. Transfer the filter_mom
schematic to layout by clicking
the schematic window command:
Layout > Generate/Update
Layout.

b. When the next dialog appear, be sure the Start Component is
P1 (port connector 1 from schematic) so that the left-to-right
layout will be correctly generated.  Click OK and you should
see another dialog indicating that all components have been
created in the layout window.

NOTE: Without the MSUB, 5 items will show instead of 6.  Either way is OK.

c. When the layout opens, verify that you have the long coupled
lines shown here.  If you zoom in on a port, you will see that it
is connected to the edge of the metal. For most Momentum
solutions, it is not necessary for the port to connect to the
middle of the line – it only needs to be on the edge.

Zoomed-in port connector.
Momentum ports
are usually
inserted in layout
if the drawing is
created in layout.
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d. The next step is to define
the substrate in Momentum.
To do this, use the Layout
commands shown here to
transfer the schematic
MSUB definition:
Momentum > Substrate >
Update From Schematic.

e. Verify that the 10mil substrate definition is now in Momentum.
Click: Momentum > Substrate > Create/Modify and you should
see the MSUB values in the dialog. Click OK if the settings are

correct.

f. You can also look at the Metalization Layers tab to see how the
drawing layers in layout are mapped into the substrate in
Momentum.  But DO NOT change anything.

filter_mom
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g. Before simulating, turn
off Momentum’s edge
mesh feature to get a
faster solution. Click:
Momentum > Mesh >
Setup. When the dialog
appears, notice there are
many mesh features.  But
for now, turn off the Edge
Mesh (uncheck box) and
click OK.

NOTE on the Momentum process - the
order of steps is: compute the
substrate definition (Green’s
functions), create the mesh or grid
pattern (cells), and then simulate.
However, you can go directly to the
Simulation and Momentum will
automatically compute the substrate
and mesh the circuit as the cell size equal to the wavelength of the highest
frequency.

h. To simulate, click: Momentum > Simulation > S-parameters.
When the dialog appears, setup the simulation: 1 to 3 GHz
using 201 points as the limit and click Update.  Then click
Simulate and watch the status window.  The Adaptive sweep
type is the default and will save time with its curve fitting- like

Be sure the
dataset name is
correct.
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algorithm.

i. When the ADS Data Display opens, notice that the Momentum
template looks slightly different – this is OK.  Zoom in to the
S21 plot and add the S-21 trace from the filter_ms circuit
simulation as shown here. As you can see, there is some
difference between the two results because Momentum considers
the coupling effects using the Method of Moments technique.

The next step shows Momentum’s power.

j. In the layout, notice that the filter now has the mesh pattern on
it. Zoom in to look at it.

k. Next, draw a simple crude rectangle (click icon) about 60 or 70
mils and about 2000 mils long  along the length of the coupled
line  - this will represent a trace or some other metalization
near the filter as shown here.

When you draw the
rectangle, notice that the
cursor begins drawing at x-
y 0,0 as shown here.  Also,
you can roughly measure
using the cursor by clicking
in layout and watching the

W: 60 -
70 mils

L : about 2000 mils or slightly longer then the filter

Spacing between the filter and the
rectangle is about 10 mils on this
end.

MS Filter with wide trace
along side for Momentum
simulation of coupling
effects. To measure,

Rectangle

Circuit vs Momentum  simulation.
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values change here.

l. With the filter and rectangle on the layout, perform another
Momentum Simulation with a new dataset name such as:
filter_mom_strip.  Then click: Momentum > Simulation > S-
parameters and when the dialog appear, simply change the
dataset name as shown here and click Apply and Simulate.

m. This simulation will take a little longer (several minutes)
because there are now more cells and therefore more
computation time is required.  When the data display appears,
you should see that there is a resonance somewhere near the
bandpass or its edges, depending upon your rectangle as
shown here.  This is the type of simulation that can only be
accomplished with Momentum.  Afterward, close the layout and
data display windows.

Narrow
resonance at
2.05 GHz due
to coupling
effects of
rectangle.
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5. Transient Analysis on the filter

a. Save the current filter schematic design and data display.

b. Open the schematic of microstrip filter_ms and then save it
with a new name: filter_trans.

c. Modify the schematic to look like the one shown below starting
by deleting the S-parameter simulation controller
and the S-parameter terminations (Terms). Keep
the MSUB.

d. From the Sources-Time Domain palette insert a
VtSine at the input.  It is recommended to use
Time Domain sources for Transient analysis.

e. Insert a 50 ohm resistor at the input and on the output.  While
you could leave the Term there, it is always better to set up
circuits and simulations that have commonly used components.
Also, label pin/nodes Vin and Vout as shown.

f. From the Simulation-Transient palette,
insert a Transient simulation controller
and set the Stop Time and MaxTimeStep
as shown. Here, the simulation will
begin at time zero (default) and stop
after fifteen periods of the input signal
(8 ns).  In addition, the time step will
sample at twice (Nyquist rule) the rate

Sources-Time
Domain:
VtSine
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of the highest spectral component desired, here the 15th

harmonic.

g. After the simulation, insert a rectangular plot of Vin and Vout
and edit each trace (Trace Options) to place symbol at data –
this will show you the time points taken in the simulation.

h. Zoom into the plot
after 5 ns and put the
markers on the peaks
of  Vin and Vout as
shown here.

i. Write an equation as
shown to calculate the
delay through the filter:
marker_difference.  This calculates the X axis difference
between markers using the indep function (independent
variable = time).

j. Insert a list of  marker_val and use Plot Options to remove the
independent data as shown. The value is the delay through the
filter after start up (settling). Depending upon where you zoom
in and where you place the markers, your value may differ
slightly.  The delay through the filter is about  90 pico seconds

Trace Options – Linear
Tab
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as shown here.
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6. OPTIONAL - create an impedance response Data Access
Component

A DAC component is a file-based component.  It may contain various
formats of data from measurements, listed data, or any other valid file type
that ADS can read.  In this step, you will create a simple file with complex
impedance values that vary over a frequency range.  Keep in mind that the
DAC can be used to create such models as:  frequency sensitive impedances,
varactors, step functions, bit sequences for sources, time domain sequences,
and many other uses where a file is more efficient than typing in long
equations or lists on your schematic.  In general, the DAC works like this:
it is a component that points to a file in the data directory.  In this example
you create a file that will be used for the impedance parameter of an ADS
component - the simulator will simply read the file.

a.  Open a new schematic with the name: Z_DAC.

b. Refer to the schematic shown here.  Insert a termination with
ground, an equation base linear Z1P_Eqn (Z1port) from the
Eqn Based Linear palette.  Then insert an S-parameter
controller, and a DAC from the Data items palette in their
default states (no setting yet).

c. Set the S-parameter simulation as if it was the LPF: 10 MHz to
200 MHz in 10 MHz steps as shown and save the schematic
again.

  

d. Open the Windows Notepad program in Start >
Programs > Accessories.  Or use the ADS Main
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Window (Options >Text Editor) if Notepad is the default text
editor.

NOTE on DAC text files - You must not use a program that has formatting -
this is a must - such as Wordpad.

e. Write an mdf (multi-dimensional data file) file shown here and
save it in the DATA directory as: z_dac.mdf.

NOTE on file type .mdf - If necessary, use
windows file explorer to change the name if
it is saved as a .txt file.  Also, the syntax in
the first column is 4 frequency points, the
second and third columns contain the real
and imaginary impedance values at each
frequency.

f. On schematic, edit the S-parameter controller. In Parameters
tab, set to compute Z parameters not S.  In
the Display tab, check Sweep Var, Start, Stop
and set them as shown to sweep freq from 10
to 200 MHz in 10 MHz steps. You will get
interpolated data for all the steps.

g. On schematic for the Z1P, type in the value of
Z[1,1]= file{DAC1,”my_z”} where “my_z”
refers to the complex values in the file.

h. Edit the DAC as shown: Type in the
file name, select the Type, etc.  Also,
iVar1 (my_freq) is the independent
variable name and iVal1 (freq) is
the independent variable value.  As
“freq” is swept, “my_freq” will be
indexed in the file and the DAC will
return complex values of “my_z”
interpolated over the range.

i. Simulate and plot two
traces, real and imag, of
Z(1,1) as shown.  As you
can see, the Zport can be
used wherever a frequency

Generic
MDIF
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sensitive component is required.  For multiple components,
simply create different files and access them as required.

EXTRA EXERCISES:

1. Calculate the bandwidth of the filter in Transient simulation
using the rule-of-thumb: BW= 0.35 / rise time. From time zero
until about 6 ns should be the rise time.  However, use the
markers and the equations to do the calculation.

2. Create a DAC for a frequency sensitive inductor and simulate it
in a simple CLC filter. The DAC will contain the filter values at
each frequency.

3. GO back to the Momentum simulation and copy the design to
another schematic – they try using a different substrate or
simply use Momentum to create a drawing that can be
simulated in Momentum – the drawing can be a spiral inductor
or anything else.

4. Try using E-syn for another circuit type or some other design.
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射 频 和 天 线 设 计 培 训 课 程 推 荐 

 

易迪拓培训(www.edatop.com)由数名来自于研发第一线的资深工程师发起成立，致力并专注于微

波、射频、天线设计研发人才的培养；我们于 2006 年整合合并微波 EDA 网(www.mweda.com)，现

已发展成为国内最大的微波射频和天线设计人才培养基地，成功推出多套微波射频以及天线设计经典

培训课程和 ADS、HFSS 等专业软件使用培训课程，广受客户好评；并先后与人民邮电出版社、电子

工业出版社合作出版了多本专业图书，帮助数万名工程师提升了专业技术能力。客户遍布中兴通讯、

研通高频、埃威航电、国人通信等多家国内知名公司，以及台湾工业技术研究院、永业科技、全一电

子等多家台湾地区企业。 

易迪拓培训课程列表：http://www.edatop.com/peixun/rfe/129.html 

 

 

射频工程师养成培训课程套装 

该套装精选了射频专业基础培训课程、射频仿真设计培训课程和射频电

路测量培训课程三个类别共 30 门视频培训课程和 3 本图书教材；旨在

引领学员全面学习一个射频工程师需要熟悉、理解和掌握的专业知识和

研发设计能力。通过套装的学习，能够让学员完全达到和胜任一个合格

的射频工程师的要求… 

课程网址：http://www.edatop.com/peixun/rfe/110.html 

ADS 学习培训课程套装 

该套装是迄今国内最全面、最权威的 ADS 培训教程，共包含 10 门 ADS

学习培训课程。课程是由具有多年 ADS 使用经验的微波射频与通信系

统设计领域资深专家讲解，并多结合设计实例，由浅入深、详细而又

全面地讲解了 ADS 在微波射频电路设计、通信系统设计和电磁仿真设

计方面的内容。能让您在最短的时间内学会使用 ADS，迅速提升个人技

术能力，把 ADS 真正应用到实际研发工作中去，成为 ADS 设计专家...

课程网址： http://www.edatop.com/peixun/ads/13.html  

 

HFSS 学习培训课程套装 

该套课程套装包含了本站全部 HFSS 培训课程，是迄今国内最全面、最

专业的HFSS培训教程套装，可以帮助您从零开始，全面深入学习HFSS

的各项功能和在多个方面的工程应用。购买套装，更可超值赠送 3 个月

免费学习答疑，随时解答您学习过程中遇到的棘手问题，让您的 HFSS

学习更加轻松顺畅… 

课程网址：http://www.edatop.com/peixun/hfss/11.html 
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CST 学习培训课程套装 

该培训套装由易迪拓培训联合微波 EDA 网共同推出，是最全面、系统、

专业的 CST 微波工作室培训课程套装，所有课程都由经验丰富的专家授

课，视频教学，可以帮助您从零开始，全面系统地学习 CST 微波工作的

各项功能及其在微波射频、天线设计等领域的设计应用。且购买该套装，

还可超值赠送 3 个月免费学习答疑… 

课程网址：http://www.edatop.com/peixun/cst/24.html  

 

HFSS 天线设计培训课程套装 

套装包含 6 门视频课程和 1 本图书，课程从基础讲起，内容由浅入深，

理论介绍和实际操作讲解相结合，全面系统的讲解了 HFSS 天线设计的

全过程。是国内最全面、最专业的 HFSS 天线设计课程，可以帮助您快

速学习掌握如何使用 HFSS 设计天线，让天线设计不再难… 

课程网址：http://www.edatop.com/peixun/hfss/122.html 

13.56MHz NFC/RFID 线圈天线设计培训课程套装 

套装包含 4 门视频培训课程，培训将 13.56MHz 线圈天线设计原理和仿

真设计实践相结合，全面系统地讲解了 13.56MHz线圈天线的工作原理、

设计方法、设计考量以及使用 HFSS 和 CST 仿真分析线圈天线的具体

操作，同时还介绍了 13.56MHz 线圈天线匹配电路的设计和调试。通过

该套课程的学习，可以帮助您快速学习掌握 13.56MHz 线圈天线及其匹

配电路的原理、设计和调试… 

详情浏览：http://www.edatop.com/peixun/antenna/116.html 
 

我们的课程优势： 

※ 成立于 2004 年，10 多年丰富的行业经验， 

※ 一直致力并专注于微波射频和天线设计工程师的培养，更了解该行业对人才的要求 

※ 经验丰富的一线资深工程师讲授，结合实际工程案例，直观、实用、易学 

联系我们： 

※ 易迪拓培训官网：http://www.edatop.com 

※ 微波 EDA 网：http://www.mweda.com 

※ 官方淘宝店：http://shop36920890.taobao.com 
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