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Getting Started with HFSS: A Waveguide T-Junction
Conventions Used in this Guide
Please take a moment to review how instructions and other 
useful information are presented in this guide. 

•    Procedures are presented as numbered lists. A single bul-
let indicates that the procedure has only one step.

•    Bold type is used for the following:
- Keyboard entries that should be typed in their entirety 
exactly as shown. For example, “copy file1” means to 
type the word copy, to type a space, and then to type 
file1.

- On-screen prompts and messages, names of options and 
text boxes, and menu commands. Menu commands are 
often separated by carats. For example, click 
HFSS>Excitations>Assign>Wave Port.

- Labeled keys on the computer keyboard. For example, 
“Press Enter” means to press the key labeled Enter.

•    Italic type is used for the following:
- Emphasis.
- The titles of publications. 
- Keyboard entries when a name or a variable must be 
typed in place of the words in italics. For example, 
“copy file name” means to type the word copy, to type 
a space, and then to type a file name.

•    The plus sign (+) is used between keyboard keys to indi-
cate that you should press the keys at the same time. For 
example, “Press Shift+F1” means to press the Shift key 
and the F1 key at the same time.

•    Toolbar buttons serve as shortcuts for executing com-
mands. Toolbar buttons are displayed after the command 
they execute. For example,

“On the Draw menu, click Line ” means that you can 
click the Draw Line toolbar button to execute the Line 
command.

Alternate methods or 
tips are listed in the left 
margin in blue italic 
text. 
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Getting Started with HFSS: A Waveguide T-Junction
Getting Help

Ansoft Technical Support
To contact Ansoft technical support staff in your geographical 
area, please log on to the Ansoft corporate website, http://
www.ansoft.com, click the Contact button, and then click 
Support. Phone numbers and e-mail addresses for the techni-
cal support staff are listed. You can also contact your Ansoft 
account manager in order to obtain this information.
All Ansoft software files are ASCII text and can be sent conve-
niently by e-mail. When reporting difficulties, it is extremely 
helpful to include very specific information about what steps 
were taken or what stages the simulation reached, including 
software files as applicable. This allows more rapid and effec-
tive debugging.

Help Menu
To access online help from the HFSS menu bar, click Help and 
select from the menu:
•    Contents - click here to open the contents of the online 

help.
•    Seach - click here to open the search function of the 

online help.
•    Index - click here to open the index of the online help.

Context-Sensitive Help
To access online help from the HFSS user interface, do one of 
the following:
•    To open a help topic about a specific HFSS menu com-

mand, press Shift+F1, and then click the command or 
toolbar icon.

•    To open a help topic about a specific HFSS dialog box, 
open the dialog box, and then press F1.
 iv 
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1 Introduction
This Getting Started guide is written for HFSS users who 
are using the Floquet port feature in version 11 for the 
first time. This guide leads you step-by-step through cre-
ating, solving, and analyzing the results of models that use 
a Floquet port.
By following the steps in this guide, you will learn how to 
perform the following tasks in HFSS:
D Draw the geometric models.
D Modify the models’ design parameters.
D Specify solution setting for the designs.
D Validate the design setups. 
D Run HFSS simulations.
D Create 2D x-y plots of S-parameter results.
Introduction 1-1



Getting Started with HFSS: Floquet Port
Floquet Ports in HFSS
The Floquet port in HFSS is used exclusively with planar-peri-
odic structures. Chief examples are planar phased arrays and 
frequency selective surfaces when these may be idealized as 
infinitely large. The analysis of the infinite structure is then 
accomplished by analyzing a unit cell. Linked boundaries most 
often form the side walls of a unit cell, but in addition, at 
least one ``open'' boundary condition representing the bound-
ary to infinite space is needed. Heretofore a PML or some-
times a radiation boundary has been used. The Floquet port is 
a new option. 
The Floquet port is closely related to a Wave port in that a set 
of modes is used to represent the fields on the port boundary. 
The new modes are called Floquet modes. Fundamentally, 
Floquet modes are plane waves with propagation direction set 
by the frequency, phasing, and geometry of the periodic 
structure. Just like Wave modes, Floquet modes have propa-
gation constants and experience cut-off at low frequency. 
When a Floquet port is present, the HFSS solution includes a 
modal decomposition that gives additional information on the 
performance of the radiating structure. As in the case of a 
Wave port, this information is cast in the form of an S-matrix 
interrelating the Floquet modes. In fact, if Floquet ports and 
Wave ports are simultaneously present, the S-matrix will 
interrelate all Wave modes and all Floquet modes in the 
project. 
For the version 11 release, the following restrictions apply:
•    Currently, only modal projects may contain Floquet ports.
•    Boundaries that are adjacent to a Floquet port must be 

linked boundaries.
•    Fast frequency sweep is not supported. (Discrete and 

interpolating sweep are supported.)
1-2 Introduction 



2 Antenna Array
This chapter guides you through the creation and simula-
tion of the antenna array model.

D Create the Unit Cell
D Assign the Boundaries
D Assign the Floquet Ports
D Setup the Analysis
D Run the Simulation
D Create the Reports
Antenna Array 2-1



Getting Started with HFSS: Floqet Ports
Array antenna tutorial example
As a first illustration, consider the case of an infinite array of 
square aperture antennas in a conducting plane. The geome-
try of the array lattice is shown in Figure 1. The elements are 
fed from below the plane by square waveguide ports with 
dominant modal field aligned in the direction shown.

When the elements are uniformly excited so that the array 
radiates in the broadside direction, the field above the array 
is periodic. The relative positions of the periodic points where 
field values are equal may be specified by a pair of vectors, 
shown in blue and denoted a and b. These ``lattice vectors'' 
describe the geometry of the array but are independent of 
the nature of the array elements themselves. The lattice vec-
tors may be parallel-transported anywhere in the array plane 
to show corresponding field points.
2-2 Antenna Array 



Getting Started with HFSS: Floqet Ports
In the usual way, a unit cell may be analyzed to represent the 
entire array and the outline of one possible unit cell is shown 
in the figure using dotted lines.
Figure 2 depicts an HFSS model for the unit cell of the infinite 
array. The model consists of two boxes. The bottom box rep-
resents the feeding waveguide and the top box is the unit cell 
for the region above the plane. The dimensions and geometry 
of the unit cell reflect the lattice vectors of the array. Linked 
boundaries are defined on the cell walls and a Wave port pro-
vides the array element excitation.

HFSS model of unit cell with lattice vectors 
A Floquet port is used on the (top) open boundary. 
Antenna Array 2-3



Getting Started with HFSS: Floqet Ports
Create the Unit Cell Model
To create the unit cell model:
1  Open a Project and name it AGW.

2  Use Draw>Box to create an arbitrary box, and Edit>Prop-
erties as follows:

3  Select the newly created box, and edit the Transparency 
to 0.86

4  Use Draw>Box to create a second arbitrary box, and 
Edit>Properties as follows:

Position -0.33645 ,-0.33645 ,0 meter

X Size 0.6729 meter

Y Size 0.6729 meter

Z Size 1.4 meter

Position -0.3119 ,-0.3119 ,0 meter

X Size 0.6238 meter

Y Size 0.6238 meter

Z Size -1.4 meter
2-4 Antenna Array 



Getting Started with HFSS: Floqet Ports
Assign the Master and Slave Boundaries
Assign the Master and Slave boundaries to the box object as 
follows.
1  Select the face of the upper box shown in the figure, and 

click HFSS>Boundaries>Assign>Master... or right click on 
Boundaries in the Project tree and select Assign>Master...

The Master Boundary dialog appears.
2  Accept the default name as Master1.
3  Click the drop down menu for the U vector, and click, New 

Vector.
The Measure dialog and a the Create Line prompt appears. 

4  Draw the U vector of the coordinate system in the place 
shown on the face in the figure. Click on the lower right 
corner as the starting point, and drag the cursor to the left 
corner and click.

5  IClick OK to close the dialog.
6  Select the opposite face, and HFSS>Boundaries>Assign 

Slave... or right click on Boundaries in the Project tree 
and select Assign>Slave...
Antenna Array 2-5



Getting Started with HFSS: Floqet Ports
The Slave dialog appears with the General Tab selected.
7  Select Master1 as the Master boundary.
8  Draw the U Vector as shown. 
9  Check the Reverse direction dialog for the V vector.
10  Accept the other settings and OK to close the dialog.
11  Repeat the procedure for the Master2 and Slave 2 bound-

aries, as shown. The main difference is that for the 
Master2 boundary, you do check the Reverse direction dia-
log for the V vector, but you don’t check it for the Slave2 
boundary.

Assign the Wave Port
To assign the wave port:
1  Select the bottom face of the lower box.

2  Right-click, and from the shortcut menu, select 
Assign>Excitations>WavePort.
The WavePort wizard appears.

3  On the General page, accept the name Waveport1 and 
click Next.

4  See that the number of Modes is 2.
5  For the Mode one Integration line, select New line, and 

draw the line as shown, moving from the Y side towards 
2-6 Antenna Array 



Getting Started with HFSS: Floqet Ports
the X axis.

6  Accept the other settings, using Next to go through the 
other pages, and click OK.
The waveport appears in the Excitation list in the Project 
tree.
Antenna Array 2-7



Getting Started with HFSS: Floqet Ports
Assign the Floquet Port
To assign the Floquet port:
1  Select the top face of the upper box.

2  Right click, and select Assign>Excitation>Floquet Port 
from the shortcut menu.
The Floquet wizard appears.

3  For the Lattice Coordinate System, Assign the A Direction 
and B Direction as shown.

4  Click Next, accepting the Phase Delay defaults, and Next 
again to the Modes Setup page.
The default mode table specifies a pair of Floquet modes. 
The default modes both have modal indices m and n equal 
to zero and are sometimes called the "specular" modes. In 
the case at hand, the specular modes consist of two 
orthogonally- polarized plane waves propagating normal to 
the plane of the array. Specular modes are always an 
essential part of the Floquet mode set, but sometimes on 
2-8 Antenna Array 



Getting Started with HFSS: Floqet Ports
the basis of electrical symmetry, one of the two polariza-
tions may be omitted. 
The final column of the mode table is labeled "Attenua-
tion". This is the attenuation of the mode along the direc-
tion normal to the plane of the array in units of dB per 
model length unit. The value given for the specular modes 
is 0 dB since they are propagating and are therefore not 
attenuated. Higher-order modes will experience attenua-
tion if they are cut off. Modes that are cut off at a certain 
scan angle may become propagating as the scan angle is 
increased.

5  Set the Number of Modes as 2.
This fills out the Modes table with four entries. In general, 
Floquet modes are specified by two modal indices and a 
polarization setting. These designations resemble the 
textbook notation for rectangular waveguide modes, such 
as ``TE10''. The Floquet field patterns are different, how-
ever.

6  See that the Frequency is set to 299.79 Mhz, and select 
the radio button Use Scan Angles to Calculate Lattice 
Phase Delays.
Almost always you should select the top radio button to 
use Scan Angles on this panel and on the corresponding 
panel in the Slave boundaries. This automatically synchro-
nizes the phase of the Floquet port with that of the linked 
boundaries, which is essential for a correct solution. The 
scan angles in were filled in automatically when the scan 
angles were previously set in the Slave boundary setup 
panels.

7  See that the Scan Angles for Theta and Phi are 90 degrees.
8  Click OK to close the dialog.

The 3D Refinement tab controls which Floquet modes par-

Note The default specular pair of nodes is sufficient for this 
simulation. 
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Getting Started with HFSS: Floqet Ports
ticipate in 3D adaptive mesh generation. The default set-
ting the Floquet modes will not participate in 3D adaptive 
refinement. 
To understand what this means, recall that in any model 
with Wave, Lumped, or Floquet ports, there is a 3D modal 
field pattern associated with each defined mode. This is 
the 3D field pattern corresponding to stimulation of the 
one mode, with all other modes match terminated. The 3D 
mesh that is created by HFSS on subsequent adaptive 
passes is actually a compromise designed to adequately 
represent all modal field patterns simultaneously. 
When a specific modal field pattern is of interest, greater 
solution efficiency is achieved by adapting only on the 
basis of the one field pattern. In the case at hand, the 
modal pattern corresponding to excitation of the Wave 
port is of principal interest. Hence the default setting of 
the 3D refinement tab which ignores the Floquet modal 
field patterns in adapting the 3D mesh.
The Post Processing tab specifies a de-embedding dis-
tance. Just as in a Wave port, de-embedding is an optional 
post processing step employed when the phase of the S-
parameter elements is of interest. The interface for de-
embedding a Floquet port is the same as that for a Wave 
port. For this example we omit specifying any de-embed-
ding.

9  Accept the other default settings, and OK to close the Flo-
quet wizard.
The Floquet port appears in the Project tree under Excita-
tions.

Create the Project Variables
To create project variables:
1  On the menu bar, click Project>Project Variables.

This displays the Properties window for the Project.
2  Click the Add button.

This displays the Add Property dialog.
2-10 Antenna Array 



Getting Started with HFSS: Floqet Ports
3  Set the Name as $phi_scan, and the value as 0 deg.
4  Click OK. 

This closes the Add Property dialog adds $phi_scan as a 
variable in the project Properties window.

5  Click the Add button to display the Add Property dialog 
again.

6  Set the name as $theta_scan and the value as 0 deg.
7  Click OK.

This closes the Add Property dialog adds $theta_scan as a 
variable in the project Properties window.

8  Click OK to close the project Properties window.
Also, it should be mentioned, when using scan angles in unit 
cell models, the plane of periodicity (here the array plane) 
should be parallel to the global coordinate x-y plane. 
Although not absolutely required, adhering to this natural 
convention insures the simplest and clearest relationship 
between scan angles and the structure being modeled.

Setup the Analysis
To setup this analysis:
1  Right click on Analysis in the Project tree, and select Add 

Solution Setup.

This opens the Solution Setup dialog.
2  On the General tab, set the Solution frequency to 299.79 

Mhz. Set the Maximum Number of Passes to 5, and the 
Maximum Delta S as 0.02.

3  On the Options tab, check the Do Lamda Refinement box, 
and set the Lambda target Use Default.

4  Set the Maximum Refinement Per Pass to 30%, the Mini-
mum Number of Passes to 5, and the Minimum Converged 
Passes to 2.

5  Select First Order Basis function, and click OK to accept 
the Setup.
Antenna Array 2-11



Getting Started with HFSS: Floqet Ports
Run Analysis and View Results
Use HFSS>Analyze to run the analysis. After completion, 
right click on the Results icon in the Project tree, and select 
Solution Data.

The figure shows matrix data panel after the simulation is 
complete. Since phase is unimportant for this case, only mag-
nitudes are shown. There are several things to note.
•    The S-matrix is a 4×4 matrix and inter-relates the Wave-

port modes with the Floquet modes.   
•    The Floquet modes in the S-matrix are listed next in the 

order specified in the Floquet port setup panel. By refer-
ring to this panel, we are therefore reminded that 
FloquetPort1:1 refers to the TE00 Floquet mode and 
FloquetPort1:2 refers to the TM00 Floquet mode.

•    The first column of the matrix gives the modal amplitudes 
for a unit stimulation of the Wave port, i.e. the array act-
ing in "transmit mode". The first entry, 0.222, is the mag-
2-12 Antenna Array 



Getting Started with HFSS: Floqet Ports
nitude of the active reflection coefficient of the unit cell. 
The third and fourth (row) entries give the power coupled 
into each of the two Floquet modes. Virtually all the non-
reflected power is coupled into the first Floquet mode. 
The excited Floquet mode represents a plane wave leaving 
the face of the array.

•    The third and fourth columns of the S-matrix indicate the 
power couplings for individual excitation of each of the 
Floquet modes. The physical picture of an exciting Floquet 
mode is a plane wave incident on the infinite array from 
above. In the case at hand, each Floquet mode transfers 
most of its power to the Wave-port mode with the same 
polarization. In these cases think of the array acting in 
"receive mode".

Parametric Sweep of Scan Angle
To illustrate more aspects of the Floquet port interface, we 
now seek the active reflection coefficient of the array as a 
function of scan angle. When the scan direction is in the E-
plane of the array, the array exhibits a beautiful example of 
scan blindness at an angle of 27.5 degrees. To demonstrate 
this and other phenomena, we will set up a parametric sweep 
to make an E-plane scan from broadside (scan = 0) to endfire 
(scan = 90 degrees).
To setup a parametric analysis:
1  Right click on Optimetrics in the Project tree, and select 

Add Parametric.

This displays the Setup Sweep Analsysis dialog with the 
Sweep Definitions tab selected.

2  Click the Add button.
This displays the Add/Edit Sweep dialog.

3  From the Variable drop down menu, select $theta_scan.
4  Select Linear step.
5  Set the Start as 0 deg, the Stop at 90 deg, and the Step as 

3 deg.
6  Click the Add button to accept the settings, and OK to 

close the Add/Edit Sweep dialog.
The Setup Sweep Analysis dialog includes the $theta_scan 
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variable definition.
7  Click the General tab and see that the Sim Setup has 

Setup1 with the Include checked.
8  Click the Options tab and see that Save Fields and Mesh is 

not checked, and that Copy Geometrically Equivalent 
Meshes is checked.

9  Click OK to close the dialog.
The Parametric setup is listed under Optimetrics.

Prepare the Modes for the Parametric Sweep

1  Reenter the Floquet port setup panel and click on the 
modes tab. 

The current pair of modes, appropriate for broadside scan, 
will need to be supplemented by additional modes for 
larger scan angles. We will use the modes calculator to 
determine a set of modes adequate for all scan angles of 
the simulation. 

2  Invoke the modes calculator by clicking on the modes cal-
culator button. 
These inputs, in addition to the known lattice vectors, are 
the additional information required to create a set of rec-
ommended modes for the Floquet port. They are purely 
for the purpose of the mode selection and do not affect 
the model set up. Therefore we may freely vary the 
choices here to explore different scenarios and the effect 
on the recommended set of modes.
With this in mind, we will do the following:

3  Select 10 modes for the port. Most likely we will trim the 
resulting list, but requesting this many gives a good pic-
ture of what modes are necessary and what are not.

4  Set the frequency to 299.97 MHz, which is the actual fre-
quency of simulation. If the problem setup contained one 
or more frequency sweeps, usually this value is set to the 
highest frequency to detect higher-order propagating 
modes.
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5  Select to choose scan angles rather than phase angles and 
set the phi scan angle to 90 degrees (E-plane) and the 
theta scan angle to the largest value that will be used, 
here equal to 90 degrees. 
The most extreme scan angle should require the largest 
number of propagating modes of all scan angles, so we 
select the Floquet modes to use on this basis.

6  Click OK to leave the calculator and to compute and view 
the recommended list of modes. The modes table is as 
appears in the Figure. 

We note the following. 
•    There is a new pair of propagating modes, the TE0-1 and 

TM0-1. The propagating nature of these modes, at the 
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scan angle of 90 degrees used to select the list, is indi-
cated by the attenuation value of 0 dB.

•    The specular modes TE00 and TM00 are still in the list, 
numbered as modes 3 and 4.

•    There are now 6 additional modes in the list, numbered 5 
through 10, all cut off, with the attenuation levels given in 
the right-most column.

At this point we can accept this list by clicking OK and run the 
simulation. However, it is always good policy in terms of simu-
lation efficiency as well as ease of interpretation of results to 
eliminate unnecessary modes.
Since modes 5 through 10 are cut off, even at the extreme 
scan angle, they are candidates for exclusion. The first pair, 
modes 5 and 6, have an attenuation of 64.97 dB per meter. 
Since the length of the unit cell is 1.25 meters, either of 
these modes generated at the rectangular aperture will expe-
rience attenuation of 1.25 * 64.97 = 81.21 dB by the time it 
reaches the Floquet port. This suggests that theses modes 
may be neglected in the simulation. A similar picture applies 
to modes 7 through 10.
7  Therefore eliminate the cutoff modes from consideration 

by decreasing the number of modes in the Number of 
Modes box to 4. 
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Note that the list is trimmed from the bottom up and now 
only the TE0-1, TM0-1, TE00 and TM00 remain.

8  As a matter of preference, we might like to have the spec-
ular modes listed first in the computed S-matrix. 
Therefore move them to the top of the list by dragging 
each corresponding line by the square box at the left of 
each row. 
The final appearance of the modes table is shown in the 
following figure. 

9  Click OK to accept this set of modes and then run the para-
metric sweep. (This will take some time.)

Viewing the Results of the Parametric Sweep
Once the simulation is complete, the S-matrix elements as a 
function of scan angle can be examined in the Matrix Data 
panel or the Reporter. The first column of the S-matrix con-
sists of the array element active reflection coefficient and 
the coupling of the Wave port to the various Floquet modes. 
By viewing the matrix elements for a sampling of scan angles, 
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it will be immediately noted that the couplings to the TE00 
and TE0-1 modes are very small. 

To create a report showing the (active) reflection and the TM 
transmission magnitudes plotted as a function of scan angle:
1  Right click on Results in the Project tree, and from the 

short cut menu select Create Modal Solution Data 
Report>Rectangular Plot.

The Report dialog appears.
2  On the Trace tab, X: drop down menu, select $theta_scan.
3  For Y:, select S Parameter as the Category, S(Wave 

Port1:1) as the Quantity and Mag as the Function. This cor-
responds to the Reflection.

4  Click OK to create the new report.
2-18 Antenna Array 
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The new report is displayed and added under Results in the 
Project tree with the first trace listed under the plot. The 
Add Trace button is enabled in the Reports dialog.

5  Select name of the trace in the Project Tree.
This displays the docked property window for the Trace

6  Check the box for Specify Name to enable the Name field, 
and change the text to Reflection.
This changes the displayed name of the first trace in the 
Legend in the Report.

7  Add two additional traces and changes their names: 
mag(S(WavePort1:1, FloquetPort1:2)) corresponding to 
TM00 Transmission
mag(S(WavePort1:1,FloquetPort1:4)) corresponding to 
TM0-1 Transmission

8  In the Project tree select X Y Plot 1.
This displays the Properties for the plot in the docked 
properties window.

9  Edit the Name field to Reflection and Transmission and 
press enter.
The plot should resemble the following figure.
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Observe that the active reflection coefficient shows the scan 
blindness condition at 27.5 degrees. Also note that the TM0-1 
mode becomes propagating at about 30 degrees and repre-
sents the onset of a grating lobe. Beyond this point, power is 
about equally split between the TM00 and TM0-1 modes until 
the endfire condition is approached.
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3 Frequency Selective 
Surface Model
This chapter guides you through the creation and simula-
tion of the frequency selective surface model.

D Create the Unit Cell
D Assign the Boundaries
D Assign the Floquet Ports
D Setup the Analysis
D Run the Simulation
D Create the Reports
Frequency Selective Surface Model 3-1
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Frequency Selective Surface Example
Unit cells for frequency selective surface (FSS) simulations 
may be constructed using linked boundaries and two Floquet 
ports, with one port above the plane of the structure and one 
port below. The applied excitations are the Floquet modes 
themselves, usually one or both specular modes. As a direct 
result of the field solution, the reflection and transmission 
properties of the FSS are cast in terms of the computed S-
matrix entries interrelating the Floquet modes.
This is somewhat in contrast to the simulation setup when 
PMLs or radiation boundaries are used to terminate the unit 
cell. In these cases, in addition to the boundary setup, one or 
more incident waves are defined separately as the excitation. 
The transmission and reflection properties of the FSS are then 
automatically computed for the user as a post-processing 
operation on the field solution.
Example Model
The example to be considered here is a conducting screen 
containing a rhombic lattice of circular apertures. The lattice 
geometry is shown in Figure 1 in which a pair of lattice vec-
tors are drawn in blue. The angle between the lattice vectors 
is 60 degrees.
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Consider a plane wave incident normally on the screen with 
polarization aligned as indicated by the red arrows in the fig-
ure. The transmission loss magnitude and phase as a function 
of frequency are the quantities of interest. The frequency 
band is 8 to 20 GHz.
A simple unit cell model has been created and is shown in Fig-
ure 2. The lengths of the side walls are 1.73 cm, the circular 
aperture diameter is 1.2 cm, and the cell is 4 cm high. 

Figure 2- Unit cell for rhombic lattice
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Create the Unit Cell Model
A simple unit cell model has been created and is shown in Fig-
ure 2. The lengths of the side walls are 1.73 cm, the circular 
aperture diameter is 1.2 cm, and the cell is 4 cm high. 

Create the Rhombic Object
To create the rhombic object.
1  Open a new project and name it rhombicArray

2  Click Draw>Line, click an abitrary point to set the starting 
point, click three more arbitrary points, then return to the 
close the line by clicking again on the starting point. 

3  Right click to display the shortcut menu and click Done. 
This creates an initial the polyline object. 

4  Look in the History Tree and expand it under 
Sheets>Unassigned>CreatePolyline, select the first Cre-
ateLine to display the docked properties for that line.

5  Edit the Point1 coordinates to 0,0,0 in cm units.
6  Edit the Point2 Coordinates to 0.865, 1.4982, 0 in cm 

units.
This moves the first polyline segment, and gives it the 
dimensions required.

7  Repeat this process with the next three CreateLines in the 
history tree, and edit their Point1 and Point2 values as fol-
lows:

The creates the rhombic sheet that you can use to create 
the rombic cell. You may which to make a copy of the 
object as a first step in creating the aperature object.

8  To transform the 2D sheet object into the 3D cell object 
select the it and click Draw>Sweep>Along Vector.
This displays the Measure Data dialogue, and also enables 
the entry fields on the Status bar for coordinates and 

CreatLine Second Third Fourth

Point1 0.856, 1.4982,0 2.595,1.4982, 0 1.73,0,0

Point2 2.595,1.4982, 0 1.73,0,0 0,0,0
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units. The status bar message says “Input the first point of 
the sweep vector.
You can enter the sweep vector either by clicking or via 
the status bar. In this example, use the status bar.

9  On the status bar, enter 0 in the X, Y, and Z cells to define 
the starting point, tabbing to change cells. Accept the 
defaults for the coordinates and units and press Enter.
This places an indicator on the first vector point, and 
changes the status bar message to “Input the second point 
of the sweep vector.” The cell labels show dX, dY, and dZ, 
for the distance.

10  In the status bar, enter 0, 0, and 3, accepting the default 
coordinates and units, and press Enter.
This draws an indication line from the starting point to the 
end point, and displays the Sweep Along Vector dialog.

11  In the Sweep Along Vector dialog, accept 0 deg as the 
draft angle, and select round from the drop down menu as 
the Draft type. Then click OK.

12  This completes the sweep., converting the sheet object 
into a solid.

13  Next move the Object by selecting the object and click-
ing the Move icon. 

14  This opens the Measure dialog and the enables the X, Y, 
and Z cells on the status bar for you to Input the reference 
point for the move vector. 

15  On the status bar, set the Z value to 0, and press Enter.
16  In the status bar, set the dZ value to -1.5 and press 

Enter.
This moves the rhomboid to the proper position.

Create the Aperature Object
If you have made a copy of the rhombic sheet, you can use 
that. If not, repeat the process in steps 1- 7.
1  Click the copy of the rhombic sheet.

2  Select the properties and specify the X and Y dimensions 
as 1.73 cm.
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3  Click Draw>Circle draw circle inside the rectangle by 
holding the cursor over the center of the rectangle, where 
a round dot will appear under the cursor. When the dot 
appears, click the button, and drag towards the edge of 
the rectangle and click to draw the circle.

4  Open the properties dialog for the circle and set the radius 
as 0.6 cm.

5  Select both the circle and the rectangle, and click Mod-
eler>Boolean>Subtract.
This opens the Subtract dialogue.

6  Move the Rectangle name to the Blank parts list and the 
circle name to the Tool parts list.

7  Click OK to close the dialogue and create the aperture by 
subtracting the circle from the rectangle.

Move the Aperture to the Rhomboid
To move the aperture to the rhomboid object:
1  Select the aperture object and click the Move icon.

2  Drag the aperture object inside the rhomboid.
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Assign the Master and Slave Boundaries
Assign the Master and Slave boundaries to the rhomboid 
object as follows.
1  Select the face shown in the figure, and click 

HFSS>Boundaries>Assign>Master... or right click on 
Boundaries in the Project tree and select Assign>Master...

The Master Boundary dialog appears.
2  Accept the default name as Master1.
3  Click the drop down menu for the U vector, and click, New 

Vector.
The Measure dialog and a the Create Line prompt appears. 

4  Draw the U vector of the coordinate system on the 
selected face. Click on the lower left corner as the start-
ing point, and drag the cursor to the right corner and click.

Master1
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5  In the Master Boundary dialog, for the V Vector, check the 
box for Reverse direction, and OK to close the dialog.

6  Select the opposite face, and HFSS>Boundaries>Assign 
Slave... or right click on Boundaries in the Project tree 
and select Assign>Slave...
The Slave dialog appears with the General Tab selected.

7  Select Master1 as the Master boundary.
8  Draw the U Vector as shown. Accept the other settings and 

OK to close the dialog.
9  Repeat the procedure for the Master2 and Slave 2 bound-

aries, as shown. The main difference is that for the 
Master2 boundary, you do not check the Reverse direction 
dialog for the V vector, but you check it for the Slave2 
boundary.
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Assign the Perfect E Boundary
For this section, you assign a Perfect E boundary to the apera-
ture.
1  Select the aperture from the history tree.

2  Select HFSS>Boundaries>Assign>Perfect E or right click 
on the Boundary icon in the Project tree and select 
Assign>Perfect E from the shortcut menu.

3  Accept the default name and click OK to close the dialog.
4  The PerfE1 boundary appears in the list under the Bound-

ary icon.

Assign the Floquet Ports
This section helps you assign the Floquet ports to the top and 
bottom faces of the model.
1  Select the top face of the model, and click HFSS>Excita-
Frequency Selective Surface Model 3-9



Getting Started with HFSS: Floquet Ports
tions>Assign>Floquet Port

The Floquet Port wizard appears, showing the General 
page.

2  For the Lattice Coordinate System, from the drop down 
menu for A direction, select New Vector.
The Measure Data dialog appears, and the Create Line dia-
log tells you to Draw the A lattice vector on the plane of 
the face. 

3  Draw the a vector as shown, clicking on the corner nearest 
the Z axis to start, and then clicking on the corner along 
the X direction. 
When you make the second click to complete the vector, 
the Measure Data and Create line dialogs disappear, and 
the Floquet Port wizard reappears, showing that the a 
vector is Defined.
Repeat the process to draw the b vector as shown.

4  Click Next in the Floquet wizard to set the Phase Delays.
5  Select the Input Lattice Phase Delays radio button, and 

click Next to go to the Modes setup page.
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6  On the Modes setup page, enter 14 as the Number of 
Nodes.
This fills out the Mode table to 14 entries with initial 0 val-
ues.

7  Click the Modes Calculator button for assistance in setting 
up the modes.
The Modes calculator appears. 

8  Accept the values by clicking OK to close the Calculator.
This fills out the table with calculated values.

9  Click Next for the 3D Refinement page. 
10  For Mode 1, click the Affects Refinement checkbox, and 

click Next to for the Post Processing page.
11  Check the box for Deembed, and specify the Distance as 

1.5 cm.
12  Click OK to close the dialog.

The first Floquet port appears under the Excitations icon 
in the Project tree.

13  Select the bottom face of the model, and repeat the pro-
cess to setup the second Floquet port.

Setup the Analysis
To setup this analysis:
1  Right click on Analysis in the project tree, and select Add 

Solution Setup.

This opens the Solution Setup dialog.
2  On the General tab, set the Solution frequency to 20 Ghz. 

Set the Maximum Number of Passes to 10, and the Maxi-
mum Delta S as 0.02.

3  On the Options tab, check the Do Lamda Refinement box, 
and set the Lambda target as 0.2.

4  Set the Maximum Refinement Per Pass to 20%, the Mini-
mum Number of Passes to 6, and the Minimum Converged 
Passes to 2.

5  Select First Order Basis function, and click OK to accept 
the Setup.
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Setup the Sweep
To setup the Sweep:
1  Rightclick on Setup1 in the Project tree, and select Add 

Frequency Sweep.

The Edit Sweep dialog appears.
2  For the Sweep Type, select Interpolating.
3  For the Frequency Setup, select Linear Step. Then set the 

Start as 8 Ghz, the Stop as 20 Ghz, and the Step Size as 0.2 
Ghz. 

4  For the Interpolating Sweep options, set the Max Solutions 
as 50, and Error Tolerance at 0.5%.

5  Click the Advanced Options button to display the Interpo-
lating Sweep Advanced Options dialog.

6  Set the Minimum Solutions to 5, and the Minimum number 
of Subranges to 1.

7  For Interpolation Convergence, select the Use Selected 
Entries Radio button, and Click the Select Entries Button.
The Interpolation Basis Convergence appears.

8  In the Interpolation Basis Convergence dialog, leave the 
Entry and Mode Selections as All. Then use the vertical 
scroll bar to find the FloquetPort2:1 Row, and set the 
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value in the FloquetPort1:1 column on that row to ON.

9  Use the Horizontal and Vertical scroll bars to find the row 
for FloquetPort1:1 and the column for Floquet Port2:1, 
and set that cell to ON.

10  Then OK to close the dialog, OK to close the Interpolat-
ing Sweep Advanced Options, and OK to close the Edit 
Sweep dialog.

11  Right click on the Sweep in the Project tree and click 
Analyze on the shortcut menu to start the simulation.
This will take some time.

Viewing the Results
Reports on the results.
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A report of the Phase.
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A Report of the Magnitude

Some examples of the Port Field Displays for Modes.
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Mode 2 Port Field Display

Mode 3 Port Field Display

Mode 4ort Field Display
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